WhatsApp Windows 10 installation has failed error message

By Peter Chubb - May 11, 2016

While we have been able to login into WhatApp on Windows and Mac devices, this was only possible via the web and not with a dedicated app, which as you well know does come with its limitations. However, there is now an official WhatsApp for Mac and Windows app, which is now available for download.

However, things have not been going smoothly for some users, as there have been a few issues. One of the most common is the WhatsApp Windows 10 installation has “failed error message” that has been appearing. It’s then that these affected users are asked to check their Set Up log, but many of you are unaware what this actually means.

From what we can make out from that, you could try this WhatsApp for Windows 10 installation fix, which is to right click on the downloaded app and then select run with Admin to install. We have seen people have some success by doing this, and so this should work for you. You should also check the UAC settings on your PC.

Whatsapp for Mac Keep your phone connected

Ok, so we know that this does not work for everyone, and some of you went as far as trying compatibility mode of Windows 8 to see if that would force the application to install on Windows 10, and also deleting run from administrator, but there just does not seem to be any way to install it for them. We would like to know if you have had any luck it working around this issue?

There does seem to be a few errors appearing, and so you have to ask if there will be a WhatsApp for Windows patch to resolves these issues very soon?

We did try to install the app on our iMac, and it seems the WhatsApp for Mac comes up with the message “keep your phone connected”, although they are vague on what this means, so some clarity would be good.

Follow us on Facebook, Twitter or Google Plus.

Also See: Get secret Olympic emoji on Whatsapp 2.16.7 update

WhatsApp Windows 10 installation

  • Subbie Wubbie

    Tried installing normally, then as admin, then with compatibility settings – nothing works. :/ On Win10.