OS X 10.11 El Capitan Mac system requirements for compatibility

By Peter Chubb - Jun 9, 2015

Since Apple announced its new operating system during WWDC yesterday, Mac owners have been wondering about the OS X 10.11 El Capitan Mac system requirements, as many of them are concerned about compatibility.

According to the release notes for OS X 10.11, the system requirements are the same as those were for OS X 10.10, which certainly makes it very easy. If you are currently running Yosemite, then you should have no issues updating your Mac to El Capitan.

For those of you that did not upgrade to Yosemite and so would like to know if you will be able to make the jump to OS X 10.11 El Capitan from an older version, then we will now explain what systems are supported.

OS X 10.11 El Capitan Mac compatibility

If you have an 2007 iMac onwards, then you will be fine, as you will also be with a late 2008 MacBook Air onwards, along with an early Mac mini or newer. A late 2008 MacBook is also fine, and so is the 2007 MacBook Pro or newer. Other systems that will support Capitan are the early 2008 Mac Pro and 2009 Xserve onwards.

Some of you spoke of performance issues with Yosemite, and Apple has been listening, as they have now made various improvements to its latest version of OS X so now the operating system performs much better, especially switching between apps.

Like to learn more, then visit Apple for a full preview of this latest Mac OS.

Follow us on Facebook, Twitter or Google Plus.

Also See: iMessage, FaceTime issues following OS X 10.11.4 update a coincidence

OS X 10.11 El Capitan Mac system requirements