ArcheAge launches with server teething problems

By Daniel Chubb - Oct 5, 2014

ArcheAge might have just reached its release date in North America and Europe/UK last month, but the MMORPG has been around for much longer in Korea. In fact, Korean online gamers have been playing for coming up to two years and now it’s the turn of the massive USA and European markets.

This adventure is seen as a free-to-play “fantasy sandbox MMORPG” that runs on CryEngine 3, and following the launch in these new markets it has hit a few teething problems. Overall, the launch has been a success apart from a few server glitches that were fixed pretty quick.

Early today we heard from the development team in regard to a “looping cinematic issue”, which caused the EU ArcheAge servers to not work correctly when first accessing them. This particular problem received a fix within a few hours on a Sunday, although if you saw these EU server connection issues for longer then please leave a comment below.

ArcheAge-launches

How has your ArcheAge online gaming experience been in Europe and the US? Are you hooked yet, or was your time with the online game short lived?

Other teething problems have included a banning script being “too overzealous”, so it needed to start unbanning many legitimate accounts a couple of days ago. The support seems to be really good, so if you do run into any other problems then just reach out to the ArcheAge team on Twitter.

Personally, we love what we’ve seen so far and look forward to seeing how online gamers in Europe and the US take to ArcheAge throughout the rest of 2014.

Follow us on Facebook, Twitter or Google Plus.

ArcheAge-launches-with-server-teething-problems

  • George Alexandru Azaru

    Any news about a Linux port?