Adobe Flash player update fixes Mac, PC, Linux risk

By Updated on

There’s an old Adobe Flash player security risk that is now getting fixed with a recent update for Mac, PC, Linux. Within the last 48 hours, Adobe released a security update for Flash Player 14.0.0.125 along with some older software versions. In a nutshell, certain vulnerabilities were patched that might allow an attacker to take over your computer.

If you haven’t installed the latest Adobe Flash player update, then you should do so right away on Linux, PC, and Mac OS X. You can read the full security release on Adobe’s support website, although you should download the latest software on this page at adobe.com.

Google Chrome users will see their Adobe Flash Player given an update automatically, so if this is you then you’re most likely already using the latest version.

You can also find out Adobe Flash player system requirements like memory, processor, minimum web browser version, and more. This is broken down by the platform you’re using with Windows, Mac OS, and Linux specs featuring on this page. The last security risk patch we reported on was back in February.

Also See: Adobe Summit 2015 dates

Adobe-patch-Flash-Player-security-risk