Mac OS X Yosemite system requirements

By Peter Chubb - Jun 24, 2014

It’s been a couple of days since Apple delivered its keynote on the OS X Yosemite and iOS 8 and now that the dust has settled a little, Mac users have started to wonder if their system will be compatible, as they never managed to watch the entire WWDC 2014 keynote.

The new version of Mac OS X comes with a ton of new features, all of which are better explained in the video below, and for those of you who will want to update the moment the new operating system is ready for download, then you will want to know the Mac OS X Yosemite compatibility and system requirements?

If you want to run Yosemite on your iMac, then it has to be at least 2007 or newer, the MacBook Air has to be late 2008 or later and the MacBook Pro 2009 or later. As for the standard MacBook, just make certain that yours is late 2008 or early 2009.

Mac OS X Yosemite compatibility

As for other models of Mac, the Mac Mini needs to be 2009 or newer and the Xserve early 2009. However, we would like to point out that when I signed up for the OS X Yosemite beta sneak peak it stated that you have to have Mavericks running on your machine. This makes us wonder if those of you who never updated to Mavericks will have to do so first in order to enjoy Yosemite.

iOS 8 compatible devices – You will need to have an iPhone 4S or later, iPod touch 5th generation, iPad 2 or later, which also includes the iPad Air and the iPad mini.

Follow us on Facebook, Twitter or Google Plus.

Also See: MacBook Pro with Touch Bar UK status update to ‘Shipped’ status

Mac OS X Yosemite compatibility and system requirements