iOS 5 release not compatible with iPhone 3GS: Possible Ultimatum for consumers

By Alan Ng - May 25, 2011

We have some important details to share with you now, as it has been rumored that Apple’s upcoming iOS 5 update will not be compatible with the iPhone 3GS, meaning that consumers will have to upgrade to the iPhone 4 or even iPhone 5 to make use of the new features.

The news has surfaced from Apple Insider, who cite editor Eldar Murtazin for the information. Murtazin posted the following update on his Twitter account, seemingly suggesting that he has inside information on Apple’s upcoming software update:

”Just one comment. Apple iPhone 3Gs wont be upgradable to iOS 5.x. iPhone 4 will.”

For those of you who are currently still using an iPhone 3GS, or even worse, have just purchased one – how do you feel about this? It will be a low blow if this bombshell turns out to be true, and very surprising tactics from Apple. iPhone 4 owners are unaffected by this of course, but spare a thought for 3GS owners who presumed that they would be able to enjoy the lovely features of iOS 5 as well.

Either way, this rumor will be sorted out very shortly, as Apple’s WWDC 2011 conference takes place on June 6th. If you are a 3GS owner, give us your insight into this head scratcher.

Also See: Apple UK Store skips Friday sales

  • Jonathan

    If iOS 5 screws up my 3GS as much as iOS 4 screwed my 3G, this comes as good news to me

    I accidentally “upgraded” to iOS 4 when it first came out and I still had a 3G.

  • Anonymous

    I been excited for this for ages and now there are rumors that my 3GS won’t be compatible (: Well the cheap iPhone 5 rumour better be true!